GMC jimmy fuel pump?

Recently I have had problems with my 1989 s15 jimmy and the fuel pump. Ive tried a new pump and new relay but the pump is still intermittent if anyone
might have a suggestion please post back or email me at snipped-for-privacy@yahoo.com
Thanks Bmx24
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
GMC jimmy fuel pump? Group: alt.autos.gm Date: Tue, May 24, 2005, 10:53pm (CDT+1) From: snipped-for-privacy@aol.com (bmx24) Recently I have had problems with my 1989 s15 jimmy and the fuel pump. Ive tried a new pump and new relay but the pump is still intermittent if anyone might have a suggestion please post back or email me at snipped-for-privacy@yahoo.com Thanks Bmx24
Checks your ground also the pins in your connector for corrosion or loose pins..If your ground and connector is good ...Then pull the fuse box and check to make sure the wire going to the pins are good for that fuse...Then if you still cant find it since everythig is out ...Run voltage and ground tests on the circuit and a continuity test....A bad connection a short to power or ground..And a wire with high resistance can all cause intermitted functions.. if all else fails run a new wire out to your pump from your fuse box if it ruuns fine you know the problem is in the power feed from he box if t you know its on the ground side.. S Cook
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Re: GMC jimmy fuel pump? Group: alt.autos.gm Date: Sat, May 28, 2005, 7:57am From: snipped-for-privacy@webtv.net (SteveCook) GMC jimmy fuel pump? Group: alt.autos.gm Date: Tue, May 24, 2005, 10:53pm (CDT+1) From: snipped-for-privacy@aol.com (bmx24) Recently I have had problems with my 1989 s15 jimmy and the fuel pump. Ive tried a new pump and new relay but the pump is still intermittent if anyone might have a suggestion please post back or email me at snipped-for-privacy@yahoo.com Thanks Bmx24 Checks your ground also the pins in your connector for corrosion or loose pins..If your ground and connector is good ...Then pull the fuse box and check to make sure the wire going to the pins are good for that fuse...Then if you still cant find it since everythig is out ...Run voltage and ground tests on the circuit and a continuity test....A bad connection a short to power or ground..And a wire with high resistance can all cause intermitted functions.. if all else fails run a new wire out to your pump from your fuse box if it ruuns fine you know the problem is in the power feed from he box if t you know its on the ground side.. S Cook
your battery feed to our relay is from your fuse box..Check the pin fit and terminals on your relay also
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.