GMC Safari 1999 - asking for assistance

Trying to help an disabled person with his GMC Safari 1999, I ask this competent group for help. GMC has (to my knowledge) no official representative
i Norway, so little or no help can be expected here. The car is equip. with an Autostart-system (www.autostart.ca), but I believe the problem is to be found i the cars own system for protection against unautorized use. The car starts - with and without the Autostart-system - and then stops immidiately. Can anyone - in simle terms - tell me WHICH (security) factors influence on starting the car, assuming the basic factors as gas,electrical comp. ... are OK? In other words: Where to start searching? I'll have som OBD II-codes available in a few days, but would not be surprised if the security area is not very well covered. Best regards Niels Nielsen.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Niels wrote:

If in fact it's the factory security Passlock that is causing the problem, it's likely to be in the ignition switch area. I know that in our dealership, the first order of business would be to completely disconnect the "auto start" system, put the everything back the way it was from the factory, and then proceed with the diagnosis. Often, the installers muck something up when they install their hardware.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks to Ian, I guess we have to do what you suggested - in the end ... Hope somebody can help with the following ODB II-codes: P1631,B2947,B2960,B3031. The P-code should be a message from the PassLock, but the others?
Again, thanks for help ...
Niels.
violet_lightening snipped-for-privacy@hotmail.com says...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Actually, the P-codes are Powertrain, B-codes are Body control codes.
B2947 is "Security System Sensor Power CKT Low" B2960 is "Sec Sys Sensor Data Incorrect but Valid" B3031 is "Security System Controller in Learn Mode" and P1631 is "Theft Deterrent Start Enable Signal Not Correct"
Everything points to the Passlock system.
On Wed, 13 Oct 2004 15:14:04 GMT, snipped-for-privacy@nitek.no (Niels Nielsen) wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.