HELP URGENT

I HAVE A CAR, CHEVROLET CORSICA 3.1L, AUTOMATICALLY, AND I HAVE A BIG PROBLEM WITH IT. BY THE DAY PASSES AWAY I LOSE THE POWER OF THE ENGINE. TO REACH A
SPEED OF 50-60 KM/H NOW I NEED MORE SECONDS, MORE TIME. WHAT SHALL I DO? WHERE IS THE PROBLEM? HOW CAN I SOLVE IT?
THANKS AND I AM WAITING FOR YOUR ANSWERS.
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
There are multiple possiblities, fuel pump, filter , blocked catylytic convertor to name some, you need to get this to someone and have it checked out. Shut off your caps also.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
LOL shep..... I was going to reply to this one, but mine was going to look something like this:
Step #1 - Turn off caps
Step #2 - See mechanic

request
News==----
Newsgroups
=----
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
We had a mind meld!! How is the electrical problem going. Shep

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Fixed, I posted the fix in the apropriate thread. But the fix was to remove and clean the remote battery stud.
Steve

http://www.autoforumz.com/Chevrolet-HELP-ftopict137532.html
120,000+
News==----
Newsgroups
=----
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.