Intermittent CEL 1997 2.4 litre Cavalier

1997 2.4 litre Cavalier, manual transmission.
When accelerating from a stop and through the first 2 or 3 gears, check engine light comes on and remains lit for 10 to 20 seconds before finally flickering
and going off. This happens each time I accelerate from a stop. Doesn't matter if engine is warm or cold. Other than that, the car drives fine.
Any ideas what might be causing this? Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Your Cavalier is OBDII compliant. You need to have the codes read out to determine what is failing. It could be anything. Many auto parts stores will read the code, AutoZone's for one....

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Tried using a scan tool, but no codes are stored. I'm assuming that the codes are only stored when the CEL condition exists and are only retrievable if I have a continuously lit CEL?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
super snipped-for-privacy@hotmail.com wrote:

The codes are stored with or without the light, and some codes can be generated (and stored) without the light even appearing. Not sure how your car's system is wired, but it could be something as simple as low rpm low oil pressure, low oil level, slipping belt, or coolant temp temporarily out of range.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
And the scan tool you used was? You need to be able to look at freeze frame data, current codes, pending codes and advanced data. A generic code reader doesn't give all the data....

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ah, I think that's the problem. My friend's scan tool can't read pending codes, and since I don't have a CEL on all of the time, he can't tell me what it is.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
We recently got my teenage daughter a '97 Cavalier Raly Sport. Lately, I've noticed that the "Check Engine Light" have been on constantly. I have not noticed any change in the vehicles handling.
Today, I decided to get it checked out in hopes that it was not anything major. I drove it over to the local AutoZone and had them do a diagnostic check. It came back that the fuel cap was at fault. He went ahead and reset th system and said if the light went on again, I would need to repalce the cap. Being an inexpensive part ($7.99) I went ahead and replaced it.
I am a happy camper!!
Jes

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@sbcglobal.net says...

--

Cheers!

Jan

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
check for chaffed wire around the clutch line unde the hood some where not routed right
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.