Knocking - 93 Grand AM

I own a 93 Grand AM 3.3 V6. When engine is warm, I get mild knocking sound from left (belt) side of engine. Any idea what it may be?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I have the same car, and heard what you described a few months ago. Worried me when I heard it because it sounded like a rod knock. A stethoscope showed it to be from the water pump and a new pump fixed it. Hope yours is the same. But I think it knocked when cold too - impeller or bearing was loose. Could be mine was worse than yours before I noticed it. Only similar knock like that I've heard was a PS pump or a rod, but on different cars.
--Vic
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

You should clarify: What engine? Knocks on idle, acceleration, both?
My 3.4 ticks at idle (not on acceleration). I was told it was piston slap. It's been doing it for 50,000 miles with no worsening. Yours may be something totally different though.
RE
I am not Proteus
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Look closer, dude: 3.3 V6
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
DB wrote:

That engine had a known problem with the cam thrust bearing that produced a cam knock. I had a 92 with the 3.3 with the cam knock. I finally gave it to charity at 227k miles.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Seems to be the harmonic balancer hitting the plastic shield. All noise coming from the shield and not the block. Not bad. Hey, how tight do I need to make the bolt holding the balancer? Getting it off took 4 hours and about 500 pounds of torque. Don't want to go through that again. When I put it back on, I didn't brace the balancer, but slapped the breaker bar handle with a sledge a few times. Sufficient?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
DB wrote:

You are probably fine. Engine rotation will tighten back to 500. I don't remember the numbers for mine anymore but I do remember it took a 3/4 inch impact and a full day to get the old one off. The starter bump vs. breaker bar would not work. I remember putting the new one on with about 10 seconds worth of impact from my 1/2 impact. You could run to a local library and see if they have a Motors Manual.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The rotation is in a direction that should loosen it, however, the threads are fine and really seem to grip. I don't know.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.