lengthy heat up time

i just installed a new thermastat, and now it takes a long time to heat up. and now it is loosing antifreeze and after it sets a while i can take the
radiator cap loose it has a lot of pressure on the cap any help is appreciated. Ed
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

up.
Why did you change the thermostat? Were you having problems before you changed it??
What kind of car and engine is involved?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

up.
Well, first off if you just did something and it has caused a problem... I'm sure you can figure out what comes next.
Let's start though, with a bit more information. How about -
What kind of car are you talking about? What size engine in the car? What caused you to change the thermostat in the first place? Are you certain you installed the thermostat right side up and not upside down? Where is it leaking antifreeze from?
When you reply please take the time to use punctuation and reasonably complete sentences. It's too much of a hassle trying to figure out what people are saying when they don't use punctuation and you're the one looking for help, so make it easier on people here to give you that help.
--

-Mike-
snipped-for-privacy@alltel.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.