Low coolent

1999 Monte Carlo 3.1 188k. (end user)
Had the EGR head gasket problem fixed around 100k. High use day to day.
The other day noticed the low coolant light on in the am
going to work. Came back home and filled her up (overflow).
Took her easy on the way to work going thru numerous heat up cool down cycles. Still on at lunch. Cracked open radiator and it was full. Resevore is full and I can drive the car all over town and the temp gauge work fine and car operates at normal temps. Top hose is under pressure and filled with coolant. But the light continues to stay on. Sometimes it blinks and other times it is steady.
Does this sound like trapped air and the bleeder valve need to be opened?
Thanks in advance.
Craig
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

if indeed radiator is full then you should suspect 'coolant level sensor' (common in those yrs. i have replaced hundreds). its mounted in pass. side end tank of radiator, 2 wires, retained with metal hairpin clip.............as far as trapped air=do make sure all air is purged when your done with this repair.....................kjun
--
The Source For Premium Newsgroup Access
Great Speed, Great Retention
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thank you kjun
Craig
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.