Lumina 1990 front engine mounts

I have a 1990 Lumina that has had a few problems. One of which the engine cradle bolts rusted off and allowed the engine to fall to the ground and un-couple the steering while driving down the highway. NHTSB had a recall
on this and it was supposed to have been fixed by a Quad City Chevy dealer a couple years before we owned it. Turns out they were paid for the recall work but did not perform it. No one was hurt and damage was paid for by GM so i guess they got away with this one....anyway now the front upper motor mounts appear to be oblonged and need replaced. (probably from the engine falling to the ground and haning on them!) I have also noticed that the car seems to wander quite a bit as if there is a low tire or something. Could it be that the wore out motor mounts are the problem? Does this allow the front end to "slop" around? thanks for any info....
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I'd have it rechecked at a GM dealer. The engine mounts are quite possibly related, so I'd see if I could have GM pay for them. The wandering -- maybe. If the cradle has been securely attached and the steering fixed properly, then no, I can't think of a reason they're related. More likely a worn front end component.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.