My 1995 Buick Riviera

Please, please please can someone help me. I have a 1995 midnight blue Riviera that I love dearly. It has just turned over 52,000 miles and when it is running it rules. I have the 3800 engine package with the
supecharger (man that thing makes it fast). Anyway, here lies my problem. About a month ago, the fuel pump died. I replaced it and all seemed well for about a week. Then for no apparent reason, the car would start and run for 2 to 5 seconds then die. I checked all the wiring and vacuum hoses to make sure i didnt knock anything loose yet all seemed well. Still, the car starts, runs for 2 to 5 seconds and dies. I am thinking one of the sensors has given up the ghost but I wanted to ask you expert people your opinions first. Which sensor would you all expect? Im in dire need here so any help you can give me would earn my eternal gratitude. Thank you sooooooooooooo much......WesG
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What did you put it in for a fuel pump, new aftermarket, used or OEM fuel pump? What brand is it? If you got a cheap one from a parts store it could be a dud.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I agree. Either the pump is bad or you installed wrong. On Tue, 17 May 2005 08:20:16 -0400, "Steve Mackie"

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Get a fuel pressure gage on it and see what happens when it dies.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.