mysterious sputtering on a 99 buick regal gs

When i hit the gas kinda hard my car starts sputtering like crazy. I noticed when i get to 1 or 2 psi boost on the supercharger thats when it really sputters otherwise im fine. It really does it when the cars warmed
up versus when its at the lowest temp. Some one give me a clue please no one knows wat it is.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

When was the last tune up (plugs and wires) done? What about fuel filter change? Air filter change? I assume you have the 3800 Series II Supercharged engine. I have the same one. How many kilometers or miles on the engine?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Plugs and wires are fine and theres 90k miles on the car. I havent checked the fuel filter though I am getting a new one put in. If that dont fix it wat else can it be cause i got brand new fuel injectors in also.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

How many miles are on the plugs and wires? As for other causes, the only car I have owned that did this was a '91 Bonneville with the 3800 Series I, and the cause was a bad coil pack. If changing the fuel filter doesn't do anything, and you don't have too many miles on the plugs and wires, you might need to take the car in to get it looked at.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.