need help for injectors

hi myself navneet from new delhi ihave a gm opel astra club problem is there is spark at plugs but no fuel at injectors so it does not starts. can anyone help why is it so.
also ow can i check my crankshaft pos. sens
--
Posted using the http://www.autoforumz.com interface, at author's request
Articles individually checked for conformance to usenet standards
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
What year/engine/mileage is the car? Are there any DTCs? Is the SES/MIL/check engine light on? Do you have power at the injectors? Is there fuel in the rail itself? Is there fuel in the tank? (don't laugh, I've seen it) Did you check the fuel pressure? When you crank the engine is there a ground pulse at the injectors?
All questions to help us help you. ;)
Steve

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"Steve Mackie1" wrote: > What year/engine/mileage is the car? Are there any DTCs? Is > the > SES/MIL/check engine light on? Do you have power at the > injectors? Is there > fuel in the rail itself? Is there fuel in the tank? (don't > laugh, I've seen > it) Did you check the fuel pressure? When you crank the engine > is there a > ground pulse at the injectors? > > All questions to help us help you. ;) > > Steve >
> > > hi myself navneet from new delhi > > ihave a gm opel astra club problem is there is spark at > plugs but no > > fuel at injectors so it does not starts. can anyone help why > is it so. > > also ow can i check my crankshaft pos. sens > > > > -- > > Posted using the http://www.autoforumz.com interface, at author's request > > Articles individually checked for conformance to usenet > standards > > Topic URL: http://www.autoforumz.com/GM-help-injectors-ftopict107186.html > > Visit Topic URL to contact author (reg. req'd). Report > abuse: > > http://www.autoforumz.com/eform.php?pI9953
thanx for your kind suggestion. fuel pump is ok throwing fuel. there is fuel . return line is working fine. while cranking there is ticking sound at injectors (all 4) when checked directly at battery injectors work fine can cps be faulty ?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sun, 13 Mar 2005 05:11:47 -0000, navneet

Has anyone put any fuel "additives" in the tank? You might have plugged injectors if the rail is pressurized......
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Not necessarily, just because they are working when manually firing them doesn't mean they are working when cranking. There should be a connector somewhere between the fuel injectors and the computer. It will have the same number of leads as there are injectors. These are the control wires for the injectors, you have to make sure you have the right one. Unplug it, stick a test light to the battery positive (+) and one of the leads on the computer side. Have a friend crank the engine over and watch the test light, is it flashing? If so, maybe the injectors are clogged, if not, something else is wrong. Usually if an engine managment switch/sensor goes bad, the check engine light will be illuminated.
Again, you have to let us know if the check engine light is on, which engine you have and the year/mileage of the vehicle to get proper help.
Steve
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.