Olds 88 Engine Quits

When starting out in morning and only when temp is cold (below 30 F, say) and just before the engine has fully warmed up (after 3 miles or more driving) the engine suddenly runs rough and quits AND the gas petal freezes
in place. A hard foot jab to the gas petal releases it and I can immediately restart the engine and car has no more problem thereafter while driving. This ALWAYS happens on each cold day. On the other hand if the car is first allowed to warm up in the driveway it NEVER happens (engine does not quit on warmup or when driven thereafter). Any clues? (Bought new 1995, 48,000 miles).
Alex
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
It sounds like the throttle plate in the throttle body is freezing ala the old carb days,of course todays cars have a way of heating the the throttle body to prevent this, first I would have the throttle body cleaned and checked for coolant circulation into the tb, small hose from by pass pipe should be warm/hot.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks for the info. This trouble started three years ago. Alex

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.