P0742

Reference my earlier post.. The TCC stuck open is the OBD II code. Car is 2001 Buick Century with 110000miles. Sorry about the wrong code. Thanks ernie

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
The first thing I would do is change the transmission fluid. Maybe several times if it has never been changed. Also check wires and plugs. If it is original fluid I would NOT have a flush done.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The transmission fluid and filter was changed at 50000 and 100000 miles. After getting the car home from the shop I did not erase the OBD II codes since they had cleared on their own. I did erase the code yeaterday and road tested the car today ( no codes set). So I think the problem is the wiring. If I can find the right plug I will try to clean it. Does anyone know know where it is? There are several. Thanks ernie
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
After resetting codes you need to drive it for a week or so because all the drive cycle codes are reset. Some of these take several drive cycles to complete. Many codes won't be set until the drive cycle codes are complete. Also the code may never come back...

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.