Re: Trans Mount sliding around Caprice

Thanks for the replies. I took it back to the shop that put in the new trans mount a year ago. They said "wow, the 2 bolts are just hanging there!",
referring to the 2 bolts that are supposed to go up through the mount, into the trans. I thought , but did not say "Yeah, because you guys forgot, or where too lazy to tighten them up, when you put the new mount in ! ". Anyway, the mechanic spent a half hour tightening up the 2 bolts ( they were way, way out. Hard to think they just backed off that much by themselves ! ). I didn't yell at anyone, and I didn't pay them anything, either, for that half hour, and they didn't mention anything about paying.
It's hard to find an honest, competent, and reasonably priced shop !!
These guys are dirt cheap, but I am starting to wonder about the quality of their work. I think they might have been the ones to bust my trans mount in the first place when they replaced the front u-joint 2 years ago.
bitch, bitch, bitch... So thanks for the info. I used it to solve the problem.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"Lecher9000" wrote

I think that you will find, that in this trade, this is a pretty accurate statement.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.