Service Engine Soon/Temp Light

my 1990 buick century this morning while driving on the highway, the service engine light and the temp light came on at the same time. it felt like the car downshifted and i released the gas, both lights went
off... i wont have a chance to get to autozone til the weekend for them to read the code... does anyone have any idea what this could be.. it happend twice within 2miles, but stopped there after.. i drove another 25 miles to work and nothin else happed...the light came on about 20mins into my drive
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
my 1990 buick century this morning while driving on the highway, the service engine light and the temp light came on at the same time. it felt like the car downshifted and i released the gas, both lights went off... i wont have a chance to get to autozone til the weekend for them to read the code... does anyone have any idea what this could be.. it happend twice within 2miles, but stopped there after.. i drove another 25 miles to work and nothin else happed...the light came on about 20mins into my drive
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
grim reaper wrote:

Maybe it's out of coolant? Your car is obdi. You don't need autozone to read the codes.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Tue, 08 Mar 2005 03:49:43 GMT, " Paul " <"

how do i read the code then? and no, i checked the coolant when i got to work it was fine. plus the duration of the temp light/service engine light was too fast for it to be overheating, it was on for less the 2 seconds. then both lights shut off.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
grim reaper wrote:

Try here: http://www.troublecodes.net/GM / There is so much info on the web on obdi that I don't even bother to bookmark it anymore.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.