Smoke from engine, leaking somewhere

Hi,
When my brother drove home tonight with a Buick Regal 94 3.8L, he noticed the ABS light came on so shortly after he stopped at a parking lot and opened up the hood, found out the engine was smoking (white steam type
smoke) so I'd imagine the engine was overheating.
He called me then I went over to check it out. Basically, after about half an hour I got there, the passenger side front has a very large spot of looks like coolant on the ground. It was dark outside but with the flash light shining on the fluid, it looks a bit greenish. The passenger side front got splashes everywhere. The coolant tank was covered with the fluid pretty much as well as the engine side where the timing belt is.
I got CAA to tow the car to the garage and when he jacked up the front, he believes it's one of the lines. I'm hoping that's what it is and not an engine damage. I guess I'll find out by tomorrow.
What do you think? What's the repair like if it was the lines? I'd imagine a lot of labour though?
Thanks,
Simon
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Newbie wrote:

If you have coolant all over the place on the passenger side, it's likely that the water pump is leaking. It will leak right onto the serpentine belt and throw it everywhere. It is possible that it might be a heater hose or the lower rad hose. I guess you will find out when they have a look at it.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hi Ian,
Thanks for your message.
It was the coolant bypass fitting that broke, the smoke was caused by the serpentine belt getting saturated. Here's what they replaced:
a) Fitting b) Thermostat c) Belt d) Gasket
Problem was when we picked up the car, within a min or so after starting the engine, the ABS light would come on and stay. It was doing that just before my brother noticed the smoke from the front too last night. Not sure if there's something wrong with the ABS system. Not sure what the repair is like with ABS?
Thanks,
Simon

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Newbie wrote:

Ah yes...I'd forgotten about those shitty plastic fittings. They often get brittle and break off. Hopefully, they installed the updated metal one. I don't think you can get the older plastic style anymore anyway.

Could be related, maybe. I think the right side wiring harness runs very close to the front of the engine, possibly some coolant has intruded into the connection. You have to have the ABS module scanned and see what the code/s is/are before anyone can diagnose the problem.
Ian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.