Thanks to aarcuda

"Rodan" wrote: (1992 Buick Roadmaster 350 TBI).
Idles at 1200-1500 RPM cold or hot, runs rough, feels exactly like a stuck automatic choke, but there is no
choke - it's fuel injected. The (ODB-I) shows no malfunction codes. I removed the IAC valve (it looks like new) polished the pintle and seat and reinstalled it with no change in performance. I will remove the EGR valve tomorrow. Is there something else I should check? ___________________________________________
"aarcuda69062" wrote:
Check the gasket between the throttle body and intake manifold. I'll bet it's sucked in. ___________________________________________
Well, I checked everywhere for vacuum leaks, including under the throttle body, and didn't find the problem. As usual, I decided to start throwing parts and money at it. I bought a new IAC valve first, thinking it might lower the idle speed, so I could then look for the miss.
Miraculously, the IAC valve fixed everything; the idle dropped to the correct 550 rpm and the rough running vanished.
So why am I thanking aarcuda? Because he took the time to offer a suggestion from his experience which I might never have considered. I have been spared many dollars and skinned knuckles by the knowledge shared here by alt.autos.gm posters. And I do the same for others here even though I am sometimes ridiculed by professional auto technicians.
Thanks again to aarcuda, and to all those who have the courtesy and the courage to offer help to others.
Rodan.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Look for vacuum leaks, around the throttle body base is common. Sorry AAR, couldn't resist, Shep.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Aarcuda is worth listening to.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Definitely.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Okay, you guys are making me blush.
oh, in case you're all wondering...
...I mailed out the checks today ;-)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.