Throttle Position Sensor

OK - I have a '86 chevy capric classi with a 305 in it - slowing getting it running good - am getting a error code that says the throttle position sensor is bad - have replaced it - still get the
same code.
is there something else that it could be - or did I just happen to get a bad one? It is pain to replace, so really don't want to do it again - especially, if there is some else that could be causing the problem.
Any the "fuel economy" guage on the dash - when the car is in Drive - it is near the top when cruising down the road, when I go to overdrive, the guage drops about 1/4 of the way down - was wondering if this is normal - of if everything evens out in the end, becouse the engine is not turning as fast when it is in overdrive.
Thanks for any help,
Scott
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Learn how to test the TPS. It is simple. It could be wiring or the computer. Economy is what it says. In OD you are using less fuel.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Woody you did better then me deciphering that post, unbelieveable!!

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.