wiper not parking and staying on widshiled

I have a 2001 Chevy Venture mini-van. I have an ongoing issue with wiperblades not parking correctly. When using intermitten delay, the wipers stay in an upright position on the windshield. The wipers should
rest at the bottom of window.
"Mechanic shop" has replaced the wiper motor several different times, the "plate mechanism" that attaches to the wiper motor has been replaced, and he has made other adjustments.
He now wants to replace the wiper transmission but I believe this is not the issue because he can not explain why he wants to replace the transmission.
Has anyone had this issue before and if so how did you fix it? Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
There is a small tab that gets bent. My mechanic removes the top of the box and with a screwdriver straightens the tab. they work fine and park fine after that-2003 Montana.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Try this:
Turn the ignition on, engine off. Put wipers on "HI" then to "OFF". If the wipers won't park, unplug the wiper switch and see if they park. If they do, replace the switch. If they don't, there may be a short somewhere, or mechanical binding.
Steve

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.