01' odyssey A/C damper noise

I have a 01' odyssey we bought new and have 106k and still running strong. (with second trany) My wife has been complaining about a clicking noise in the dash by the
glove box sometimes when the A/C is on. I finally found (what I call) a servo that controls the air flow on the passenger side (there is also one on the drivers side). When the A/C is satisfied the motor gets to it's neutral position and hunts a little back and forth (this is her clicking noise). If I turn up or down the temperature control the damper moves and stays there until it get satisfied and when it gets back to it's neutral position and hunts a little back and forth again until it calls for more or less air.
I unplugged and cleaned the contacts on the dash A/C and connectors as well and the plug on the servo.I removed the servo and found I can't take it apart without braking it.
My concern is this a temperature sensor problem with the A/C or a servo problem. Has anyone had this problem?
Don
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Have you ever replaced the cabin filter? Crud leaves in the way of the damper? Wear in the damper. The <dka_donh> wrote in message >I have a 01' odyssey we bought new and have 106k and still running

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yes did that.

-
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.