06 Civic EX ticking noise from cam cover area

06 civic ex 137k miles
I have posted about this car before. It has had a crank, difficult start problem for 18 months. Before Christmas it progressed into a crank, no start problem
Had it towed to local Honda dealership, who removed the coils plugs and compression tested the cylinders, compression is good. From previous tests they have done, spark and fuel injection are good. No trouble codes. They removed the cam cover and camshaft sprocket bolt and told me the camshaft sprocket key had broken in the camshaft and that the car needed a replacement engine. Their total cost for installation of a junkyard engine $5500. I called BS on this and had the car towed home.
Well yesterday morning I tried to start the car. It cranked and started no problem. Since them I must have started it 10 times without a problem. Runs without a problem.
It does however have a ticking noise when idling. The noise apears to come from inside the cam cover. It sounds like a badly adjusted valve clearance, tick tick tick, except that it is not regular, it comes and goes.
Anybody have any idea what this noise might be, and how could it relate to the crank/hard start, crank/no start problems.
Camshaft Position Sensor ????? Is it a mechanical device or stictly electrical.
Al Moodie.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.