12v outlet "finicky"

2004 Accord, tried the outlet for the first time two months ago when I got a new cell phone charger, Verizon standard model - doesn't work, the light doesn't come on. I try the same charger in an old Altima,
works fine. I assume my outlet is bad.
I finally take my Accord in for standard service and tell them to look at the outlet. They say it was loose, fuse blown, they replace fuse and reinstall outlet. I pick up the car and try it - still no light. Fuse is blown again. Replace fuse. Service droid picks up her cell charger, same model as mine, plugs it into my outlet, seems fine, light comes on and stays on. Plug mine in again and the light comes on for two seconds, then fuse blows again.
They tell me Honda outlets are "finicky", and I should get another cell charger.
Any sage advice here?
Thanks.
Josh
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I had a similar problem with one of my cell phone chargers. I simply took a piece of foil (not very much at all) and wrapped it around on of the negative contacts on the plug for the charger. It was just enough to make a good connection to the sidewall of the outlet.
As I said, it only takes a small piece of foil. Anything too big and you will run the risk of creating a short circuit.
Brian
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Must be a common problem. I have an '04 Accord and also had trouble with a power inverter I plugged into the 12v outlet. Had to wiggle it around before it made contact.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.