1992 Honda Civic Hatchback starting problem

Hello, the other day I was driving somewhere and suddenly the car lost power and died. In the shoulder lane, I tried to start the car and it did not
want to catch. All it did was turn and nothing else. I managed to get it towed back home, and the first thing I did is check the fuses (all of them are fine). Next I tested for a spark and there was none. I decided to take appart the distributor to do an ignition system, ignition coil and ignition control module check and found that all the readings are fine. I would like to check and see if the signals from the sensors in the distributor are good, and I was wondering where I could find out what they should look like. I am also going to test and make sure that there is continuity in the cables. I can hear the fuel pump go when turn the key to the on position. Besides that I am stumped and have no idea what else I should check or do. Anyone have any ideas? If so, please let me know. Thanks in advance.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

<snip>
Igniter.
--
TeGGeR

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Did a few tests and it looks like the igniter (ICM) is the culprit. I will buy one, replace it and then let you know how things went. Thanks so much for your help.
AJ

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Car runs fine. Thanks for your help.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.