1993 Accord smog/EGR issues

Hello everyone, Im in need of help with my 1993 Accord EX. It is not passing smog for NOx. This is pointing to the EGR system so I started troubleshooting.
I was able to get the manual off line and went through the troubleshooting diagnostics. Right now it seems all the system components are functional which is making it very hard to troubleshoot. This is what I have done so far: I have found that the EGR valve only opens for a brief moment when I rev the motor. I confirmed that the EGR Control solenoid is only getting voltage for the same duration that I have vacuum on the EGR. I performed all the troubleshooting the manual suggested EXCEPT replace the ECU/ECM. The EGR gave me changing voltage at the ECU when I applied vacuum to the valve and stalled the motor when applied vacuum. EGR good. I ran voltage to the EGR vacuum control solenoid and got about 6 in/Hg. Is this acceptable? I am starting to think that the vacuum control valve might need more flow in order to give me more of the 8 in/Hg the manual is calling for. What does everyone else think? The other thing I have not done is drive the car with the vac gauge connected. Does anyone have any thoughts? Thank you, -S

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
Add image file

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.