1996 Civic starting related

Mine is a 1996 civic auto transmission, 213K km. Last winter (<15C outside) there was no problem starting as it used to start immidiately after turning it ON. But now a days in hot summer conditions, evey
morning temperature falls as low as 5C and starting takes more time (2-3 seconds) than it usually takes when the engine is warm. I am sure it did not happen in the Winter. I checked TeGGeR's FAQ section but my problem does not fall into any categories there.
More specifically, when I try to start a cold engine, it sounds chugga-chugga-chugga and then starts (in one attempt, of course). My spark plug wires are original NGK and they are new. Car is well maintained. If this persists, I wonder whether it will start in the coming Winter!
Suggestions are always appreciated. Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Correction: I meant temperature in Winter was below minus 15C.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
How old is the battery?
I would start by checking its voltage per the five quick checks at http://home.earthlink.net/~honda.lioness/id13.html

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Actually I don't know as I bought it used. So I will check it with the mechanic on my next oil change. Thanks.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.