1996 Honda Accord Air Conditioning Not working

Car has never had an air conditioning problem. However, 2 days ago after going through a car wash, I turned the A/C on and it failed to blow cold air. When I turn on the A/C light, the green light over the A/C goes on,
and uncooled air blows. I noticed that the car does not labor as it normally does when the A/C is engaged. Also, after checking someone else's post, I checked to see if the radiator fans were on--they were not. Are they supposed to be on? Any comments or suggestions would be greatly appreciated. Thanks, Dan
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

There's an electric clutch that engages the air conditioning pump. It's possible you damaged/shorted something with the wash. After that look for refrigerant loss, etc.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

yes the electric fans are supposed to engage with the A/C on. You have to "have" air across the condensor for the air condentioning to work.
you may just have a loose wire / connection. I would make sure the fans are working otherwise, not only when the A/C is on, or you are going to have over-heating problems.
--
Elbert Clarke
elbert.clarke@**adelphia.net
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.