1997 civic power locks

A weird thing happened the other day. I opened the door lock with the remote got in and put the key in the ignition and turned it and the door locks clicked closed and the horn beeped. Turned the ignition off
and back on and the same thing happened. Now, the remote switch won't lock or unlock the doors. I checked the fuse under the hood as well as the battery in the remote unit.They're both ok. Anybody have any ideas about this?? Thanks, Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@yahoo.com wrote:

-----------------------------
Is the door switch working correctly? If it doesn't, the car doesn't know you got in, and it might relock the car, just like your Owner's manual said it should.
'Curly'
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I got the keyless entry working. I reprogrammed the receiver. At first I couldn't get the receiver to go into programming mode. Had to pull the fuse for the radio.That after checking the fuse for the power locks. All the fuses were ok. Then when I pushed the valet/disarm button the door locks cycled indicating program mode. Why did this happen in the first place? Gremlins. Cosmic alignment of the planets. I don't know but if it ever happens again I'll know how to fix it straight away and so will you. BTW, my library has Alldata car info. Lots of good info there and found directions to program this model (in accessories). I checked the Chilton and Haynes manual at the library. They didn't tell me jack! Said to see a dealer as special tools were required. Right!! A dealer probably would've charged me 150 clams and the entire service dept. would've laughed about it for days. Don't be a chump. Fix it yourself and save big. Good luck, Bob
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Hello,
I am having the same issue. Could you please give some more details about the steps?
Thank you
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.