2003 CRV Engine Noise

I have a 2003 CRV with only 30k miles. It is still running ok but there seems to be a lot noise coming from the top front of the engine. I just noticed it last night and it went away after the engine ran about 10
minutes.
The belt seems ok and the fluid levels are fine. Could the steering pump be failing this early or is there something else that failing.
Thanks for your opinions.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Sat, 20 Jan 2007 06:54:07 -0700, Anonamous wrote:

Pretty much impossible to answer from a computer terminal.
"Could the steering pump be failing"? Sure. Anything can happen. Your best bet would be to open the hood and listen while the noise is present. See what it is coming from.
Is your steering working OK? Does the noise change when you steer? Especially when you are not moving?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Not a prime suspect but easy to check and correct: is the coolant level okay? My daughter's Accord was making a loud squalling noise like a seized bearing when she made sharp turns before the engine warmed up. Refilling the coolant (and ultimately replacing the cracked radiator) cured it.
Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.