2004 Transmission??????

My 2004 Civic EX has begun to "loose power" at all speeds, just for a second. The RPMs plummet, the car acts like I just put on the brakes, thereís a light cranking sound in the bottom center of the
dash area, and the engine light comes on. Itís very random. Sometimes I get by with a 20 mile drive with no occurrence, other times, it happens 10 times in 20 miles. And, sometimes I canít get up my drivewayÖ. The car acts like itís in neutral on a flat surface. After turning it of and on several times, Iím able to get the power I need. This has been happening for about a month now. I took it in to the Honda Service Center and they said they couldnít find anything in the code. Yet, something is wrong. Iíd appreciate any advise. Thanks, Rhonda
--
Posted at author's request, using http://www.AutoBoardz.com interface
Articles individually verified to usenet standards. Visit URL to contact
  Click to see the full signature.
Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Ask the dealer if they have a diagnostic scanner that you can drive with for a day that will capture and save intermittent codes.

Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
If a code is set it will be in the history and can be accessed even after the check engine light goes off. The service tech is probably not looking for anything but the active codes if looking at all.

Add pictures here
‚úĖ
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.