89 Accord LX Parking Lights Stay On

Hi I have a 89 Honda Accord LX. Just got to work and turn off the headlights and the hideaways did not go down as I pulled the keys out and open the door I heard a bell sound got out and saw that my parking
lights are still on. I had to disconnect the battery cable to turn off the lights. Any ideas?? Thanks
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Rick wrote:

Hard to say without seeing it, but I'd suspect a stuck relay, or something along those lines. If you need the wiring diagram you can d/l the manual from the Aerodeck site. Could also maybe be a broke switch itself, now stuck in parking light mode. I see the headlights and controller in the manual, but the parking light system seems to be separate. But if I remember right from my car, I think you do have to turn the lights all the way off for the headlights to retract. If they are on, and you turn them to "parking", I *think* the headlights stay up if they were on before.. I'll check later and let you know.. I have the same exact car. If the switch broke in parking mode, I think it might do what yours is doing. I'll let you know. I gotta go somewhere in a while, and will check it. MK
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@wt.net wrote:

I'll let you know. I gotta go somewhere in a

I checked it earlier. Yep, the headlights don't retract until the light switch is turned to off. They stay up if the switch is in the parking light position. So don't know for sure if it's a broke switch, but if it broke and broke in the parking light position, it would act as your does. I don't know how hard it is to change that switch. Might be a PIA.. MK
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks I order the switch I hope it comes in next week as I'm off for the holiday and the steering wheel has to come off, so this will be fun... I'll let you know if it works... Thanks again Rick snipped-for-privacy@wt.net wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.