91 Civic Will Not Start

Thanks for any help in advance.
I have a 91 Civic Si 1.6L. Have had it for a few years and runs like a champ until now. After a nice drive one day I came home and it would not
crank.
- At first I could hear some very light clicking noise (sounds very electrical) at the starter itself when I attempt to crank it. (No engine turn whatsoever.) During this test, I did verify that when the clutch was NOT pressed it there was NO light electrical click sound at starter so I tend to believe that the clutch switch is working. Also I took a volt meter and hooked it up to the small wire that runs to the starter solenoid and was getting different signal when clutch pedal was pressed in. -I thought it might be the starter to I took it off and went to Autozone and they hooked it up on their machine with and the starter spun right up with force! -They said it may be the starter and that sometime when it's removed the solenoid gets jerked around and it temporarily works. Since the starter seems to be working I didn't buy a new one and stuck the same one on the car. I attempted to hook up the power straight from the battery to the starter just like they did and I think I fried something in my instrument cluster because there was some smoke and my turn signal indicator in the cluster comes on when ignition is turned on. (oops!) :)
-Anyway - I tried to crank the engine - no crank. (not even the light clicking electrical noise I was getting before.) -A friend bought me a brand new (rebuilt I assume) starter and we swapped it out thinking that it may have been the selonoid with no luck. No crank on the new starter. Oh- I have good battery. -The car itself runs fine... my friend and I did a pushed compression start and performed a confidence hop around the block. The car runs fine. -I did checked all of my fuses and they all seem to be good. -At the moment, I removed my starter relay and gave it to my friend who's going to try it on his 91 Civic Si. (He lives 300 miles away and was visiting when he dropped off the starter, he will probably test it out on July 4th.)
Anyway... sorry for the long story but had to give as much information as I could to maybe get to the source of the starting problem and get some idea of where to check next.
The underlying problem is that the car is NOT CRANKING. I just want to do good troubleshooting and not start changing parts... for example, we might have just swapped out a perfectly good starter but since we installed the part we can't return it.
Again... thanks in advance for any advice.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Are you sure the battery is GOOD? It sounds like the battery. I've had a loose battery cable that had similar symptoms. It had just enough contact to light up the dash board and radio, but not enough to crank.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I will try to check that out this weekend. Headlights are strong when I tested them. I even hooked up the battery charger on it overnight. I have replaced the main relay and starter relay with no luck. (Swapped it out with a friend's car but his car starts right up.)
I will double check the clutch switch or replace it then the ignition switch. I don't know where else to go from there.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.