92 Accord Distributer

my 92 accord starting making a rubbing kind of sound under the hood. I think I narrowed it down to the distributor. Took the cap off and discovered the rotor was kind of sloppy fitting. Assumed it was worn and
replaced it and the cap. The new rotor also has some slop in it. I don't ever remember it fitting that loosely. Any thoughts? I can literally wobble it back and forth a 1/4 inch on the shaft. Did my distributor shaft shrink!?! <grin>
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Is the /shaft/ wiggling?
Is the rotor aftermarket?
--
Tegger

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

No, shaft is solid. Yes, it is aftermarket. Having my wife go to the dealer today to get one. I thought I saw at some point over the years that there were 2 different distributors. Guessing maybe I got the rotor for the one I don't have and the shaft is smaller. I'll let you know what I find out tonight with an OEM one. Thanks for the reply!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Was the aftermarket Rotor ... What a difference in rotors too!
It is still making a whining noise but not constantly. I am pretty sure it is coming from the distributor. Could it be distributor bearings? Accord has 254K miles on it.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Aftermarket sucks. Only use OEM for ignition components.
How loud is the whining noise? These do have a history of bearing failure. Remove the rotor (and leak cover under that) once more and look for red rust dust.
--
Tegger

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I did notice some reddish dust now that you mention it. Wasn't sure about it when I saw it. Is that a sign of bearing failure?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Sure is. Better replace that distributor quick. Or at least the housing that contains the shaft.
--
Tegger

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Got my new distributor today. Any trick to installing it? Timing, alignment?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Nevermind. Made note of rotor location when taking the old out and installed the new the same. Once again, runs like a Honda! Thanks a bunch for the info Tegger!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Two thumbs up!
--
Tegger

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.