93 Civic rattle - turning and engine start

After a garage changed my timing belt a couple of months ago I have noticed a rattle coming from the passenger side (left hand side) of my UK 93 Civic LSi. It occurs at about low speed only about 10-20 mph
when turning right mainly and when the engine is warm and I start it up there is a quick rattle then it goes. I think it's too late to take it back to the garage to expect them to fix it for free.
Revving the engine is smooth and doesn't rattle so I don't think it's an engine problem.
I thought it might be the engine mountings but they look OK on initial inspection. I know my suspension bushings are worn but if it was them it wouldn't rattle on engine start. If it isn't the engine mounts could it be one of the CV joints?
As usual any ideas appreiciated!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
timtech wrote:

Search: heat shield rattle / buzz at www.tegger.com
'Curly'
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

If it was the heatshield it would rattle all the time not just when turning?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I jacked up the back today and checked the suspension - my trailing arm bushings are cracked and look worn out - maybe this is it?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.