93 Civic weird gas mileage and power loss

Well, it's me again. Just as a refresher, I have a 93 civic lx 1.5L 16 valve engine with 200k miles. I recently replaced my distributor with one I got from a 92 civic lx from the yard. Ever since then I
have had this weird power loss when trying to accelerate. It goes from 0 to about 40 mph..it almost feels like it is bogged down or something. Any ideas? Also, my fuel gage will drop from full to half a tank when i travel only 100 miles, but the rest of the tank will get 200 miles or better..leaving me with around 300 miles to the tank. Is this a sending unit problem?
Thanks again, Ricky
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@gmail.com wrote:

how did you set the ignition timing with this "new" distributor? in what condition is the distributor cap and rotor arm? did you assemble with sweaty fingers?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well when I pulled my old distributor off I marked where the rotor was originally. I compared the new one to the old one and moved the rotor to match. However, when I went to put it on, the slots were completely different...i thought i had no choice but to make them match, so i did. i guess this has me thinking that my timing may be a little off and need adjusting..The cap and rotor arm were in excellent condition also. It was rather hot outside that day so i'm sure my fingers were a little sweaty
thanks, Ricky
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@gmail.com wrote:

that's not good. the timing signal it's sending your engine computer is probably wrong. you need to get the correct distributor. there's a code number stamped into the body - mine is "TD-01U" - your old one will be similar format. you need another distributor exactly the same as the original.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
yea the numbers check out for my distributors, TD-41U. i'm guessing the timing it out of whack so I will readjust it in a few days. any idea of what is goin on with the gas gauge?
Thanks, Ricky
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.