96 Civic question

Ok here goes,
'96 civic DX 5 speed,I was driving into work this morning and had the wipers on,headlights and defog.My dash lights started (how do I explain this)
acting like they were almost blinking like my emergency lights.Headlights were doing the same thing.It was raining out at the time.I kinda think it's my alternator going up on me or the belts are loose.Any thoughts on this?Oh yeah the speedometer was jumping around like a monkey on crystal meth going from 20 to 100 to 30 to ...you get the picture. Thanks in advance, Will
PS I had a prior question about whether my speed sensor or speedometer was going up on me,it WAS the speed sensor.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
That's quite a description! Never seen a monkey of meth, but I got the picture :)
Be sure the battery connections are tight and clean first. Check the voltage across the battery (you can get a cheap multimeter at sears or radio shack, if you don't have one). With the car running, you should see over 14 Volts. If not, it could be your alternator or belt so check back here.
Remco
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

My first guess is that an UFO flew above you and was trying to beem up your car but decided at the last moment to beem up the new BMW that was behind you.
Remco gave you some great advice in case I was wrong.
--
NEWSGROUP SUBSCRIBERS MOTTO
We respect those subscribers that ask for advice or provide advice.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Yeah, I hate it when that happens! :)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

The wide range of electrical symptoms points right to the battery, charging system or grounds (or UFO, of course.)
Most of the symptoms could be slipping belts, but I dunno about the speedometer. Check the engine ground - probably a braided wire from the valve cover to the frame near the radiator - for tightness at each end. Really weird electrical problems always make me think of engine ground first. As Remco suggests, from there it is checking the battery connections and voltage. I also had a battery once that was intermittently open and caused all sorts of problems while driving until I caught it in the act once when I tried to start the car... no crank. But focus on the common stuff first.
Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.