97 Civic A/C stopped working

Neighbor has this car and the A/C was fine last weekend, but no cold air yesterday.
I popped the hood and looked at a few things. * A/C Belt is tight
* A/C radiator fan does not turn on. * Almost no engine loading when A/C engaged. * A/C green light comes on when activated and stays on. * fan inside car runs normally.
I don't have any gauges to check the pressure (or know how).
Any ideas?
Dave
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 7/4/2013 11:45 AM, Dave wrote:

freon leak.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 07/04/2013 06:19 PM, Pawalleye wrote:

Will check tomorrow. What would cause the fuse to blow? The reason for the question is that this could be a symptom, rather than the problem.
Dave,
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 7/4/2013 9:12 PM, Dave wrote:

but, I would guess if it is a fuse and is replaced then if it blows again one would have to check for more problems. I am not a mechanic but I do have some experience working with automotive electric issues. Good luck
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On 7/5/2013 8:00 AM, Pawalleye wrote:

would be a good thing to check to see if there is a relay.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.