98 Accord security system--odd problem

1998 Accord EXV6, 126k miles, now driven by my son. Strange thing happened when he got off the train at 2am early this am. His remote did not work at
all. It's been on its way out over the past several weeks, and putting a new battery provided little improvement. That isn't the odd part. What is the odd part is that when he inserted his key to unlock the door, an original transponder key, the alarm (horn) went off. He could not get the horn to stop nor the security light on the door to go off. BUT he was able to start AND drive the car with the horn blaring and the security light blinking. This morning I went outside and confirmed that yes his remote is dead. I put his key in the door and the alarm went off again. This time I used the other master key and remote which worked fine. The other key was also able to disable the security system by inserting it in the driver door lock and unlocking the door. HIS key did start the car, and on one attempt did disable the security when inserted into the drivers door.
I wish all I had to do was replace the remote, plentiful on eBay, but something else seems awry.
Open to the floor for discussion. You guys have always been a great help. Matt
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Maybe I answered my own question. I went on line and got the programming instructions for the remote. I re-programmed the remote (I had to reprogram both remotes) and the bad one now works normally. The key seems fine as well. I'm still puzzled as to WHY the situation happened, but I'm happy that it at least appears to be resolved.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.