A/C has become heater, help

My honda city os six months old. Since Saturday, when I turn on the A/C. it blows lukewarm air. Turning the A/C off and leaving the fan on gives the same
result. When I turn on the A/C, the tiny green light on the button lights up but nothing else happens.
Everything was normal till Friday night. On Saturday my attendant washed the car and also cleaned it from inside. It was then that the problem started. I suspect this to be an electrical problem, perhaps a short circuit or something. I've checked the fuse and it's fine. I wonder if anyone else has faced this same strange problem. I could take the car to the dealer since it's still under warranty but the problem is, they are over a 100 kilometers away. If I could sort out this problem by myself that'd be of great help.
Thank you.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Check for oil residue around the front of the evaporator in front of the radiator. Rocks taking out evaporators is very common these days. Take it to the dealer since you are not versed in the operation and you could void your warranty by messing with it.....

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.