accord acceleration problem

hello,
I've had this problem on my 2001 4-cyl accord (automatic) for a while. It has 55K miles on it. When accelerating from a low speed, the acceleration is often not
smooth, it feels like its being kicked from behind. The problem has not gotten worse nor better. I've posted before and gotten a few suggestions and want to get advice on the comments received.
1. Automatic transmission issue - extended warranty. I checked online and this appears to be for 6 cyl cars and am not sure if my problem is really that.
2. EGR valve - how to diagnose this? I have no check engine light nor code.
3. Fuel filter - I was told in another forum that this does not require replacement.
4. spark plugs - I was told in another forum that platinum types don't require repl till 100K miles.
5. Air filter - replaced once, but didn't help.
6. Air Intake manifold - how to check if I need to get this cleaned?
7. Anything else??
Thanks for any help!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

There's a pause, and then it kicks in at high RPM, and then shifts again? Its the tranny. Flush it, and it should get better, for a while. It's the dark secret of Honda, a couple of generations of 4-speed autos do this.
My 2007 5-speed auto 4-cyl Accord is maybe just showing the first signs of this at around 20k miles. My 1999 Acura CL6 did it right off the lot, 2004 Accord 4-cyl got that way after the first year or so.
Before 1999, I was driving sticks, no problems at all!
J.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.