Civic 2002 Indicator Flasher Relay

The turn indicators on my Civic work for one or two times when starting from cold but then stop working. I assume the problem lies with the flasher relay which I believe is one of the little 'boxes' in
the fuse box under hood. However which one? Anyone know? If the relay isn't in the fuse box anyone any idea where it is and how to change it?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Edward W. Thompson wrote:

Hmm, Before that, do all the bulbs in the circuit is in good condition?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Thanks but I still don't know which is, or where is, the flasher relay!
I don't think a failed bulb gives me the symptoms I described. I thought a failed lamp caused the indicators to flash very rapidly. Isn't that correct?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

It's more likely your combination switch. Try the solution I gave "Peabody" on Tuesday.
It could also be the ICM. Do you have any other odd electrical problems, like a rear defroster that doesn't behave properly, intermittent wipers acting up, strange beeps and buzzes from the beeper? Any rust in the cowl or windshield pinchweld? Pull off the driver's kick panel trim. Any rust or wetness in there?
--
Tegger

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.