Clunking sound from 97 CRV

Each time I run over a bump I hear a clunking noise from either front or back. The dealer told me to have front and rear stabilizer bar links replaced but was
not sure whether this would fix it. A good assurance :-) for my $400. Did anybody have experienced this kind of problem on this car (97 CRV)?
I find this newsgroup quite helpful in helping me to make informed decisions. I resolved my 92 Accord hot weather starting problem through this newsgroup. Thanks to all of Honda enthusiasts out there who share their expertise and experience.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
My 01 was doing the same thing, bought new stablizers @ snipped-for-privacy@neo.rr.com, as i recall I spent about $70 for the pair and installed them my self, easy job if you have tools, metric wrenches and allens wrenches, I would recomend a pair of needle nose vice grips, to use instead of the allen wrenches for removal, use the allens on the new links.
Tom

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I left out that they are links.
Sorry
Tom

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Dario Moreno wrote:

------------------------------
Take note that it's not the stabilizer BAR that's giving the clunking noise, but rather the sway bar link (on rear), which is about 8" long, with a small ball joint on each end. Search eBay . . . they are often there for half price. I wonder if your dealer is a GOOF??? I wouldn't let him hold your Visa card just yet. You could also sign in and use the SEARCH feature at hondasuv.com. 'Curly'
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.