Coolant ingestion

1986 Accord, 225,000 miles.
Left home a week ago, all seemed normal. After a couple of miles, I noted no heat and temp gage still on Cold. Then I noticed white smoke in exhaust
behind me. I stopped and refilled radiator and drove 4-5 miles with white smoke the whole way.
Pulled the plugs and cranked it over and water was spraying out #4 spark plug hole. Drained radiator and checked compression. #1 150 psi #2 140 psi #3 170 psi #4 150 psi
I'm guessing that the head gasket is blown, but if the head gasket is leaking that much coolant, would I still be getting 150 psi pressure on that cylinder? Any other diagnosis for these symptoms?
With the age and mileage on this car, I don't want to spend much. I was planning on pulling the head, replace head gasket, timing belt, and water pump and hope I get another couple of years out of it.
TIA
John
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
JP wrote:

definitely gasket. compression tests are relatively rapid so no slow leakage will show.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Definitely head gasket; I've never seen such clear-cut symptoms as you have collected. Good job.
Your plan is sound, with the addition of having the head checked for warp and planed if out of tolerance. If the car were a decade older I'd suggest a JDM engine. If you're doing the work yourself I'd say you're on track.
Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.