COULD SOMEONE HELP ME PLEASE

I HAVE HONDA THAT SEEM TO GET NO POWER WHEN THE TEMPERATURE GETS TOO HOT OR IF I DRIVE IT MORE THAN 30-40 MINUTES. IM WONDERING IF ITS EITHER A CLUTCH PROBLEM OR TRANSMISSION? i DON'T KNOW ANYTHING ABOUT
CARS. THE CAR WILL RUN GREAT WHEN I FIRST DRIVE IT BUT AFTER A CERTAIN AMOUNT OF DRIVING AND/OR HOT WEATHER, THE RPMS JUST REVS UP SO I HAVE TO TURN IT OFF AND WAIT ABOUT HALF AN HOUR TO GET IT MOVING AGAIN. COULD SOME OF YOU GENTLEMAN HELP ME OUT WITH THIS. I'M NOT TRYING TO GET RIPPED OFF BY SOME CAR REPAIR SHOP. I APPRECIATE IT AND THANX.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
KARPROBS wrote:

The first thing to do is to turn your CapsLock key off.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

1) Turn off your Caps Lock key. English is written with both upper and lower case. 2) What year and model? 3) Mileage? 4) How long have you owned the car? 5) When did the problem first surface?
--
TeGGeR

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

I guessing here that the car has an automatic transmission, and that its losing drive when it gets hot. A slipping clutch (with manual transmission) usually does not fail this way, unless the engine is leakig oil out the rear main seal.
First step: get the transmission oil level checked. If you've never had the oil changed, have it done and see if the problem recurs.
Check back here if it does.
SD
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.