funny humming in 03 accord

Hey folks, got a weird issue that I'm not sure about.
2003 accord 4 cyl - auto
ever since I had my air filter replaced at one of those quick lube
places my car makes an extra humming noise. its a vacuum sounding hum. Tracing it down more I know the sound is coming from the air filter housing.
I opened the box while the engine was running, and the humming grew noticeably louder.
nothing seems to be affected, gas millage is the same as before, power seems the same, the only issue is this strange noise.
any ideas?
Dave
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Zephyr wrote:

They probably broke something. The world would be a much less stressful place if everyone used real mechanics or learned to do it themselves instead of letting the poorly trained hackers at your typical quick lube touch the car.
Have a look at this:
http://www.nbc4.tv/automotive/2615014/detail.html
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

"About that engine flush..." More from the same station, I expect, this is video.
Mike
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Get another filter and replace the one they put in - perhaps they broke a section of it and it's vibrating. If no change, then take it to a dealer or shop, get an estimate and make a stink with the quickie OC place.
Oh and make sure your oil filter and drain plug are tight. ;-)
Dan D '07 Ody EX Central NJ USA
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.