Heater Problem

The heater on my `97 Civic works intermittantly. No other symptoms...sometimes it works, sometimes it doesn't. Any ideas what might cause this?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Doesn't work as in temp is cold, temp is inconsistent, fan doesn't blow, makes funny noise, has a bad smell, switch sticks?
See whadda mean, Vern?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
I see what you mean! Doesn't work as in heater is turned on, fan is turned on and is moving air, but the air doesn't get hot.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

different . Probably hard to get at and expensive.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
David Glass wrote:

Did you try the most obvious? Fill the coolant reservoir to the =MAXmark, then fill the rad to the top. Repeat the reservoir part for three days and see if it appears to be 'sipping' coolant overnight. If it was, you had AIR in the system.
'Curly'
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Thanks all for the advice. DG

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.