HELP!!!! my 94 Civic is haunted

I own a 1994 Civic. When the car is on for 15 minutes or so..the blinkers (signal sights) stop working and the 4 way flashers stop working.
They work fine when the car is first started....but after 15 minutes...dead.
If I shut off the car for 20 minutes...they will work again.
I changed the flasher relay thingey...still does it.
Please help me....Kathy.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Wed, 18 Apr 2007 14:24:10 +0000, Humanvirus wrote:

I'd be looking for something affected by heat, esp under the hood.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Been there...looked at that. Got any Ideas?

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Do they then STAY working,or fail again after another 15 minutes?

check the grounds. Perhaps one of the underhood relays is bad.
--
Jim Yanik
jyanik
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
On Thu, 19 Apr 2007 02:43:25 +0000, Jim Yanik wrote:

Yeah...grounds are a PITA!!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.