Honda civic 1.6i LS auto 1996 lose of power and funny noise

Hi i have had this car now for almost 3 months, it has 100.000 miles on the clock. When i 1st brought the car it felt very smooth and a perfectly good car.
Just recently done a trip down to cornwall in the car 400 mile round trip to and from my house and started to have problems with this car.
The problem i have is that once it gets to about 4000 revs whatever gear it is in it makes a horrible sound like there is a plastic bag caught on the underside of the car almost like a whistling sound. It is worse sounding in the higher gears and i have lost a lot of power, i am struggling to do more than 60mph on the motorways. It is fine around the town below 40mph.
It almost sounds like the exhaust is blowing but when i stop put it in neutral and rev the engine it does not make this noise i am talking about..
I dont know much about automatic gear boxes as this is the 1st automatic i car i have ver brought or driven....
Any help will be much appreciated..
Many thanks and look forward to a reply
--
Posted at author's request, using moderated http://www.AutoBoardz.com interface
Thread archive:
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
yorik wrote:

Hmmm, Have you checked the fluid level?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Over drive related ?
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
2000 Civic hatch wrote:

muffler bearings more likely.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.