Idle problem on 1.6 Honda

Hi folks,
Can I pick your brains for a problem here?
Car is a 1997 Honda Civic 1.6 Auto with 80k odd miles.
Problem is with the idle but only once the car has warmed up. It
becomes erratic running between 700rpm and 2000rpm all by itself.
I'm thinking there is a problem with one of the fuel management system sensors but thought I'd ask if anyone can certainly pinpoint this to a particular sensor or has experience of the problem.
Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Just a little caveat: Pinpointing the source of a problem even with the car right in front of a technician often isn't easy. A shotgun approach is often necessary. That doesn't mean people are going to have you rebuild your engine, one bolt at a time, or anything. It means one can probably narrow the problem pretty quickly IF the poster is willing to assist in some troubleshooting and, quite possibly, going down the wrong path. One has to cover a lot of bases when diagnosing. Sometimes one nails it with the first base covered. Sometimes not.
Can you explain in more detail what is happening? Do you mean that, with the engine running but the car sitting at a stoplight, and long after warmup, it revs high?
Is fuel mileage poor in general? Does the car seem to run rough in general?
Have you done any maintenance on the car recently? Is the car maintained per the maintenance schedule, and using OEM parts?
Once you respond to some of these, we can talk about purging the coolant system (costs very little and may be the problem); checking the idle setting; checking for vacuum leaks; checking the idle air control valve; replacing the oxygen sensor.
A wonderful, free online manual for your 1997 Civic that does have a troubleshooting procedure in it for idle problems is linked at http://www.honda.co.uk/car/owner/workshop.html . Maybe start reading it, starting at the "Fuel Emissions" section where idle control and troubleshooting is discussed. Keep checking back.

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@gmail.com wrote in

Big air leak somewhere. Computer is trying to compensate for extra air.
IAC may be stuck, or a hose is disconnected.
Any work done to the car recently? Collisions?
With the car fully warma nd the idle cycling, take off the air pipe to the throttle body. Find the IAC port and cover it with your finger. Does the idle drop?
--
TeGGeR

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
snipped-for-privacy@gmail.com wrote:

------------------------------
Make sure the rad is full to the top, and fill the reservoir to the MAX mark. Drive the car and check it next morning before starting. If it's 'sipped' some of the coolant (no tap water allowed) top it up near MAX again and repeat next morning. Idle may cure itself. The temp sensors in the cooling system are 'full emersion' style, and if they aren't under coolant, the computer goes crazy trying to compensate for bogus input.
'Curly'
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
'Curly Q. Links' wrote:

for the op, do not just look at the reservoir and conclude the radiator is full! take the cap off the radiator and look inside at the actual fluid level. and use distilled water - the mineral content of tap water can greatly accelerate corrosion/cooling system problems.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
jim beam wrote:

Cheers for the link, Elle.
He has had some work done recently, Tegger, he changed the coolant thermostat because the car was overheating and since the temperature has been fine. Other than that, just normal servicing - oil and filters. I'll try the coolant maxing first as Curly and Jim have advised then check for air leaks etc.
Thanks!
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.