overheating problem!

I have tried a few different things but nothings working. Ive changed the thermostat then I noticed a hole in a hose that runs to the heater core which was leaking antifreeze so I assumed this was the
problem....no it wasnt. I checked the pressure in the radiator everything was ok, but no change. The car gets hot real fast. I let it idle for about an hour and it was fine but as I drove it got too hot. What is this?
--
Posted at author's request, using fully moderated
http://www.AutoBoardz.com/1993-Honda-Accord-forum-143.html interface
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Plugged rad. Plugged internally, that is.
Poor maintenance.
Time to boil out or replace.
--
Tegger

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
Well it IS a Honda right? (you didnt say)
Head gasket
-Speedy
GMB wrote:

Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
GMB wrote:

Yep, sounds like a clogged radiator to me too. I'd get a new one. I see loads of em on flea bay... I guess you could rebuild it, but often you will get a lifetime warranty if you buy a new one. Depends where you buy it though I suppose. MK
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.