Problem start engine Del Sol

hello to everybody, i am from italy, sorry for my bad language. i own a Del Sol vti, and from a months ago i have a problem. the engine on turns off.
ok i try to explain better. at engine hot, not cold, for example this problem is when i go back at home and turn off the engine and turn on again once garage open. turn the key, check inspection is ok, turn off the yellow led of inspection, and you listen the sound of relais when the check inspection is ended, so now you turn the key to turn on the engine. the engine starts perfectly but for a second, after a second turns off. now... i turn off the key and turn on the key and yellow led of check inspection is ok, but this time there is not the sound of relais (sound like : tick) if there is not the sound of relais i am sure the engine doesn't start again. i have to wait 4 or 5 minuts and relais will start again to do his job and the engine will start again normally. it seams that all the problem is connected to the function of this relais hoping to listen his sound. sometime the sound of the relais is ok but the engine doens't start in every way too... the only solution is to wait for 4 or 5 minuts. i repeat... the engine starts ok normally but it will turn off after one or two seconds.
Max
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
"@@@" wrote:

You need to replace or repair the MAIN RELAY. There are many articles in this newsgroup, or look for 'main relay' at www.tegger.com. It is caused by poor solder connections, which get worse when temperature under the dash rises. Hitting the dash with your hand will make the relay click if you don't hear it.
'Curly'
--
If there are a couple of _underscores_ hidden in my return address,
you'll have to remove them to reply . . . . Thanks.
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload
wrote:

Curly parla la verit. Il rel principale ("PGM-FI Main Relay") deve essere riparato.
(Translation by http://trans.voila.fr/voila )
--
TeGGeR

The Unofficial Honda/Acura FAQ
  Click to see the full signature.
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

thanks Curly, and thanks TeGGer, then this is the problem : the main relay. i will find old articles in this NG. i hope the problem is only this, i love my car and i conserve it in a very very lovely way and i could kill for her :-) ok, i thank you again, you are very kind. if you want, this is the section of my site dedicated to my Del Sol and our little spider-meeting : http://www.psqadpdk.com/crx-intro.htm push the bottons on the left and on the right, there are not more links :-)
Max :-)
Add pictures here
<% if( /^image/.test(type) ){ %>
<% } %>
<%-name%>
Add image file
Upload

Motorsforum.com is a website by car enthusiasts for car enthusiasts. It is not affiliated with any of the car or spare part manufacturers or car dealers discussed here. All logos and trade names are the property of their respective owners.